Сменить версию php

Вопросы касающиеся настройки, функционирования виртуальных серверов
Правила форума
1. Один вопрос - одна тема. Не надо задавать в той же теме другие вопросы.
2. Не пишите в чужих темах, если ваша проблема не имеет отношения к обсуждаемой.
3. Давайте полное описание проблемы - имя сайта, имя сервера, учётная запись, способ воспроизведения, скриншот ошибки.
4. Пароли выкладывать в форум - НЕ НАДО
Ответить
nerskow

Сменить версию php

Сообщение nerskow »

Как можно сменить вресию php на виртуальном сервере?
Джумла выдает Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!
lissyara
Site Admin
Сообщения: 6416
Зарегистрирован: 2009-09-19, 22:04:41

Сменить версию php

Сообщение lissyara »

какая оперционка?
если CentOS, то примерно так:

ставим утилиты yum

Код: Выделить всё

yum install -y wget yum-utils
скачиваем репозитории:

Код: Выделить всё

cd /tmp && rm -f *.rpm
cd /tmp && wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
cd /tmp && wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
подключаем их:

Код: Выделить всё

cd /tmp && rpm -Uvh *.rpm
включаем репозиторий remi

Код: Выделить всё

yum-config-manager --enable remi
обновляем весь софт:

Код: Выделить всё

yum upgrade -y
в принципе, для джумлы этого достаточно.

если же надо более новую версию, то выполнить такую

Код: Выделить всё

yum-config-manager --enable remi-php55
или такую команды

Код: Выделить всё

yum-config-manager --enable remi-php56
и ещё раз обновиться:

Код: Выделить всё

yum upgrade -y
Отправлено спустя 1 минуту 3 секунды:
также, не забываем перезапустить весь софт, а лучше перезагрузить виртуалку.
после чего, запускаем

Код: Выделить всё

mysql_upgrade
поскольку база наверняка обновилась вместе со всем софтом
Убей их всех! Бог потом рассортирует...
Ответить