cutycapt

Вопросы касающиеся настройки, функционирования виртуальных серверов
Правила форума
1. Один вопрос - одна тема. Не надо задавать в той же теме другие вопросы.
2. Не пишите в чужих темах, если ваша проблема не имеет отношения к обсуждаемой.
3. Давайте полное описание проблемы - имя сайта, имя сервера, учётная запись, способ воспроизведения, скриншот ошибки.
4. Пароли выкладывать в форум - НЕ НАДО
djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

cutycapt

Сообщение djos » 2012-04-05, 22:00:00

Сколько нужно паменти для установки cutycapt а то при установке выводит это

Код: Выделить всё

virtual memory exhausted: Cannot allocate memory
*** Error code 1
1 error
*** Error code 1

Stop in /usr/ports/devel/qmake4.
*** Error code 1

Stop in /usr/ports/x11-toolkits/qt4-gui.
*** Error code 1

Stop in /usr/ports/graphics/qt4-imageformats.
*** Error code 1

Stop in /usr/ports/www/cutycapt.
До простите меня Засранца

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги нашей хостинговой компании

Хостинг HostFood.ru

Тарифы на хостинг, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM), от 189 рублей: https://www.host-food.ru/tariffs/virtualny-server-vps/
Тарифы на выделенные сервера (Dedicated Server), от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU): https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах, от 110 рублей: https://www.host-food.ru/domains/
Часто задаваемые вопросы по хостингу: https://www.host-food.ru/faq/
Вопросы по доменам: https://www.host-food.ru/faq/domains.questions/

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 22:18:48

много, думаю...
он на qt4 - у меня мой десктоп с 4 гигами рамы в свап лезет при сборке зависимостей...
лучше установить пакетом
Убей их всех! Бог потом рассортирует...

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 22:20:06

как вариант - смените тариф на больший, перезагрузите ВПС, соберите, напишите запрос чтоб вернули нужный тариф.
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-05, 22:32:10

Теперь выдает это как установить?

Код: Выделить всё

v31164# make -C /usr/ports/www/cutycapt install clean
===>   cutycapt-20100608 depends on file: /usr/local/lib/qt4/plugins/imageformats/libqjpeg.so - not found
===>    Verifying install for /usr/local/lib/qt4/plugins/imageformats/libqjpeg.so in /usr/ports/graphics/qt4-imageformats
===>   qt4-imageformats-4.7.4 depends on file: /usr/local/lib/qt4/libQtCore.so - not found
===>    Verifying install for /usr/local/lib/qt4/libQtCore.so in /usr/ports/devel/qt4-corelib
     => No directory for /usr/local/lib/qt4/libQtCore.so.  Skipping..
===>   qt4-imageformats-4.7.4 depends on file: /usr/local/lib/qt4/libQtGui.so - not found
===>    Verifying install for /usr/local/lib/qt4/libQtGui.so in /usr/ports/x11-toolkits/qt4-gui
===>  Building for qt4-gui-4.7.4_1
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic dialogs/qprintsettingsoutput.ui -o .uic/release-shared/ui_qprintsettingsoutput.h
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic dialogs/qprintwidget.ui -o .uic/release-shared/ui_qprintwidget.h
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic: not found
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic dialogs/qprintpropertieswidget.ui -o .uic/release-shared/ui_qprintpropertieswidget.h
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic: not found
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic dialogs/qfiledialog.ui -o .uic/release-shared/ui_qfiledialog.h
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic: not found
*** Error code 127
*** Error code 127
*** Error code 127
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic: not found
*** Error code 127
4 errors
*** Error code 1

Stop in /usr/ports/x11-toolkits/qt4-gui.
*** Error code 1

Stop in /usr/ports/graphics/qt4-imageformats.
*** Error code 1

Stop in /usr/ports/www/cutycapt.
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 22:50:10

лучше

Код: Выделить всё

make -C /usr/ports/www/cutycapt clean install clean
а перед этим, в /etc/make.conf добавить

Код: Выделить всё

# Gui don't need on servers
NO_GUI=yes
NO_X11=yes
NO_X=yes
т.к. на сервере вам оно не нужно
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-05, 23:00:52

lissyara писал(а):лучше

Код: Выделить всё

make -C /usr/ports/www/cutycapt clean install clean
а перед этим, в /etc/make.conf добавить

Код: Выделить всё

# Gui don't need on servers
NO_GUI=yes
NO_X11=yes
NO_X=yes
т.к. на сервере вам оно не нужно
Все выше написаное зделал и выдало теперь такое
Qt is now configured for building. Just run 'make'.
Once everything is built, you must run 'make install'.
Qt will be installed into /usr/local

To reconfigure, run 'make confclean' and 'configure'.

/usr/bin/sed -i.bak -e 's|/usr/local/lib/qt4/pkgconfig|/usr/local/libdata/pkgconfig|g' -e 's|.*$(QMAKE).*||g' /usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/src/gui/Makefile
/usr/bin/sed -i.bak -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' -E -e 's|(.*location=).*moc|\1/usr/local/bin/moc-qt4|g' -E -e 's|(.*location=).*uic|\1/usr/local/bin/uic-qt4|g' /usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/lib/pkgconfig/QtGui.pc
===> Building for qt4-gui-4.7.4_1
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic dialogs/qprintsettingsoutput.ui -o .uic/release-shared/ui_qprintsettingsoutput.h
/usr/ports/x11-toolkits/qt4-gui/work/qt-everywhere-opensource-src-4.7.4/bin/uic: not found
*** Error code 127
1 error
*** Error code 1

Stop in /usr/ports/x11-toolkits/qt4-gui.
*** Error code 1

Stop in /usr/ports/graphics/qt4-imageformats.
*** Error code 1

Stop in /usr/ports/www/cutycapt.
Может эт сново памети не хватает?
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 23:18:00

нет. это не из-за памяти.
===
порты обновляли? софт прикладной?
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-05, 23:20:52

Порты обновлял, а софт незнаю
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 23:21:39

Код: Выделить всё

pkg_version -v | grep -v up-to-date
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-05, 23:26:57

Код: Выделить всё

v31164# pkg_version -v | grep -v up-to-date
bsdstats-5.5_1                      <   needs updating (port has 5.5_2)
cyrus-sasl-2.1.23_3                 <   needs updating (port has 2.1.25_2)
glib-2.28.8                         <   needs updating (port has 2.28.8_4)
help2man-1.40.6                     <   needs updating (port has 1.40.7)
libSM-1.1.1_3,1                     <   needs updating (port has 1.2.0,1)
libX11-1.3.6,1                      <   needs updating (port has 1.4.4,1)
libXext-1.1.2,1                     <   needs updating (port has 1.3.0_1,1)
libXp-1.0.0,1                       <   needs updating (port has 1.0.1,1)
libXpm-3.5.7                        <   needs updating (port has 3.5.9)
mc-4.7.5_1                          <   needs updating (port has 4.7.5.6)
mysql-client-5.1.61                 <   needs updating (port has 5.1.62)
mysql-server-5.1.61                 <   needs updating (port has 5.1.62)
nginx-1.0.6_1,1                     <   needs updating (port has 1.0.14,1)
p5-Authen-NTLM-1.09                 >   succeeds port (port has 1.08_1)
p5-BerkeleyDB-0.50                  <   needs updating (port has 0.51)
p5-DBD-mysql-4.019                  <   needs updating (port has 4.020)
p5-HTTP-Date-6.01                   <   needs updating (port has 6.02)
p5-Net-SSLeay-1.45                  <   needs updating (port has 1.47)
p5-XML-LibXML-1.88,1                <   needs updating (port has 1.96,1)
p5-XML-LibXSLT-1.75                 <   needs updating (port has 1.77)
php52-5.2.17_2                      <   needs updating (port has 5.2.17_7)
php52-bz2-5.2.17_2                  <   needs updating (port has 5.2.17_7)
php52-ctype-5.2.17_2                <   needs updating (port has 5.2.17_7)
php52-curl-5.2.17_2                 <   needs updating (port has 5.2.17_7)
php52-filter-5.2.17_2               <   needs updating (port has 5.2.17_7)
php52-gd-5.2.17_2                   <   needs updating (port has 5.2.17_7)
php52-gettext-5.2.17_2              <   needs updating (port has 5.2.17_7)
php52-imap-5.2.17_2                 <   needs updating (port has 5.2.17_7)
php52-json-5.2.17_2                 <   needs updating (port has 5.2.17_7)
php52-mbstring-5.2.17_2             <   needs updating (port has 5.2.17_7)
php52-mcrypt-5.2.17_2               <   needs updating (port has 5.2.17_7)
php52-mhash-5.2.17_2                <   needs updating (port has 5.2.17_7)
php52-mysql-5.2.17_2                <   needs updating (port has 5.2.17_7)
php52-openssl-5.2.17_2              <   needs updating (port has 5.2.17_7)
php52-pcre-5.2.17_2                 <   needs updating (port has 5.2.17_7)
php52-pdo-5.2.17_2                  <   needs updating (port has 5.2.17_7)
php52-pdo_mysql-5.2.17_2            <   needs updating (port has 5.2.17_7)
php52-pgsql-5.2.17_2                <   needs updating (port has 5.2.17_7)
php52-posix-5.2.17_2                <   needs updating (port has 5.2.17_7)
php52-session-5.2.17_2              <   needs updating (port has 5.2.17_7)
php52-simplexml-5.2.17_2            <   needs updating (port has 5.2.17_7)
php52-spl-5.2.17_2                  <   needs updating (port has 5.2.17_7)
php52-xml-5.2.17_2                  <   needs updating (port has 5.2.17_7)
php52-zip-5.2.17_2                  <   needs updating (port has 5.2.17_7)
php52-zlib-5.2.17_2                 <   needs updating (port has 5.2.17_7)
phpMyAdmin-3.4.10.1                 <   needs updating (port has 3.4.10.2)
phpMyAdmin-3.4.5                    <   needs updating (port has 3.4.10.2)
phppgadmin-5.0.2                    <   needs updating (port has 5.0.4)
phppgadmin-5.0.3                    <   needs updating (port has 5.0.4)
postgresql-client-8.4.8             <   needs updating (port has 8.4.11)
postgresql-server-8.4.8_1           <   needs updating (port has 8.4.11)
proftpd-1.3.3e                      <   needs updating (port has 1.3.4a_1)
python26-2.6.7                      <   needs updating (port has 2.6.7_3)
vim-lite-7.3.121                    <   needs updating (port has 7.3.480)
выше написаное зделал попробывал установить еще раз таже ошибка
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 23:38:15

обновляйте софт.
думаю, проблема в этом
--
а лучше установите пакетом и не мучайтесь
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-05, 23:42:05

Ясно тогда думаю последние вопросы
как обновить софт ?
и как устанавливать пакетами?
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-05, 23:50:10

Код: Выделить всё

pkg_add -r имя_пакета
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-06, 0:02:11

Вот так?

Код: Выделить всё

v31164# pkg_add -r xvfb
Error: Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8-stable/Latest/xvfb.tbz: File unavailable (e.g., file not found, no access)
pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8-stable/Latest/xvfb.tbz' by URL
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-06, 8:55:54

скачайте руками, для 8.2
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-06, 19:02:59

А как исправить чтоб не ввыводило эту ошибку?
До простите меня Засранца

Аватара пользователя
lissyara
Site Admin
Сообщения: 6082
Зарегистрирован: 2009-09-19, 22:04:41

Re: cutycapt

Сообщение lissyara » 2012-04-06, 19:19:37

надо где-то прописать релиз
где точно - не подскажу, никогда не озадачивался
Убей их всех! Бог потом рассортирует...

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-04-06, 19:50:52

Как же мне установить cutycapt если со всех сторон одни ошибки вылетают :O:
До простите меня Засранца

serge
Сообщения: 2464
Зарегистрирован: 2009-09-25, 15:58:07
Контактная информация:

Re: cutycapt

Сообщение serge » 2012-04-07, 9:17:18

djos писал(а):А как исправить чтоб не ввыводило эту ошибку?
Можно вручную скачать пакет и той же командой, но уже без ключа -r поставить.

djos
Сообщения: 85
Зарегистрирован: 2012-02-19, 17:53:34
Контактная информация:

Re: cutycapt

Сообщение djos » 2012-05-11, 22:15:20

установил пакетом как узнать где теперь файл который запускает cutycapt?
И вообще установлен ли он?
До простите меня Засранца